Google Chrome: New PBPS data system requirement

Please remember that the new PBPS data system recommends using the latest versions of Google Chrome, Firefox, or Safari to ensure full functionality of the system. If you do not already have Chrome, please contact your IT department to get it installed. Users have experienced problems using Explorer (and Edge).  The problems experienced with Explorer are things like the system not displaying correctly, the screen freezing up, fields not filtering properly, etc.

Leave a Reply